Saturday, 09 July 2022
  4 Replies
  840 Visits
Hi, just nearing the finishing of my KMT DIY build. Upon plugging in the PCB to my computer (via the left computer port) I get the following errors from windows:

and the "Firmware update" page of the KeyMouse software has no devices listed in it. Happens with both hands. There's no lights on the PCB (not sure if there is supposed to be) and I felt around and nothing feels hot (no short).
Any ideas?
6 months ago
That is very strange. Is this the left port when viewed from the top? I've seen similar errors if I plug in the device to the wrong port. If plugging in the other port doesn't work, is it recognized when plugging into another computer?
6 months ago
Huh, I tried every single port on my computer and only found one that worked... Mix of USB 2.0 and 3.0, but the one that works happened to be USB 3.1. Thanks for the quick response (on a weekend too!), took a couple mins to type this out but I'm happy my fancy new KMT is functional!!
6 months ago
I'm very glad you got your KeyMouse fully assembled and working :) That's awesome!
Strange that only 1 port worked. I wonder if it's power related. Maybe the 3.1 USB port puts out more power.
6 months ago
Yeah I agree, very strange. My laptop had no problem which is what keyed me into trying every single port. I've got a controller plugged into one of the ports and I assume that the rumble feature would draw more power than a keyboard? I tried with the backlight connected/disconnected too in case the lights were a bit much.
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below.
Supported: gif,jpg,png,jpeg,zip,rar,pdf
· Insert · Remove
  Upload Files (Maximum 2MB)
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.